All times are UTC - 6 hours   |  Page 2 of 2

Dion Designs

Make phpBB 3.0.12+ compatible with PHP 7!

Make phpBB 3.0.12+ compatible with PHP 7.0!

Posted: December 14th 2017, 10:37am
by Dion
ReCAPTCHA 2 is not part of the phpBB 3.0.14 core -- you must have added that yourself as a MOD.

I'm glad you were able to patch it yourself. Your patch will fix the PHP parse error, and if you never update to PHP 7.2, it will be a permanent fix. If you want a permanent fix, you must change the name of the constructor function (which in phpBB 3.0.x is the same name as the class) to the following:

Code: Select all
	function __construct()

Make phpBB 3.0.12+ compatible with PHP 7.0!

Posted: December 20th 2017, 5:48am
by io2
where do i that?

Make phpBB 3.0.12+ compatible with PHP 7.0!

Posted: December 20th 2017, 9:12am
by io2
done. thank you for help. :)
Merry Christmas and Happy New Year. :)